Wife's Waggy "Walter"...

Area to show off your Custom Build threads.
Post Reply

ScramblerCJ8
Posts: 35
Joined: Mon Mar 11, 2019 9:08 pm

Re: Wife's Waggy

Post by ScramblerCJ8 » Tue Mar 19, 2019 11:50 am

:roll: :roll: Hi Ted, don't know if I'm coming to late on the fuel issue but, I did a tbi conversion on my sons cj with the 304 engine. Fabed the system out of a 88 chevy truck with a 350 tbi. What I did on the fuel was, first installed a vw Jetta pre pump on the jeep's sending unit, had to shorten the tube, drilled a hole on the sending unit plate and runned the wire thru, added an insulator that I scavenged from some other sending unit. Then I built a canister that holds about 1/4 of fuel in it and mounted on the frame closed to the tank, and then next to it the electric fuel pump. Still works after 10 years.
Just remember that those electrics pumps don't suck the fuel from the tank very well, but pushes it, so best location is closed to the tank.
PS, you have to drop the tank to do that.


ScramblerCJ8
Posts: 35
Joined: Mon Mar 11, 2019 9:08 pm

Re: Wife's Waggy

Post by ScramblerCJ8 » Wed Mar 20, 2019 9:03 am

Ted, another thing I remember. I did set the timing at 0 degrees or tdc, like on the Chevy 350 and it run crappie and pingged under heavy acceleration, so decided to set the timing at 8 degrees, the AMC 304 specs setting, and solve the problem. You may want to check with Bill and pick his brain about it.

Post Reply

Who is online

Users browsing this forum: No registered users and 18 guests