Radio feedback

Stock FSJ Tech Area
Post Reply

Topic author
hanger
Posts: 44
Joined: Sun Dec 16, 2018 8:09 am

Radio feedback

Post by hanger » Tue May 07, 2019 4:45 pm

So I’ve had this 87 GW for about 6 months and after about 10 minutes of having any FM station playing I start getting feedback in the speakers. Not engine noise but static really bad. Doesn’t happen with AM stations or the CD player just FM stations. It has an Alpine radio CD player with Rockford Fosgate speakers. Sounds great except for the static feed back. Anyone have any idea what it could be? Thanks.

User avatar

Stuka
Site Admin
Posts: 9132
Joined: Thu May 12, 2011 5:53 pm
Location: Sonora, CA
Contact:

Re: Radio feedback

Post by Stuka » Wed May 08, 2019 6:33 am

Check the antenna hookup on the back of the head unit, make sure it is clean. Otherwise, its most likely in the line going to the antenna itself. I guess its always possible its the head unit itself, but my guess is that its the line.
1981 J10 AMC 258 with HEI and Weber 32/36 DGEV Carb, T176, NP208, D44/M23 with 4.56 gears and Detroit Locker, 6" lift, 33x12.50 Cooper STT's, BJ's Offroad Rear Dozer Bumper.
2017 JKU Rubicon Lifted and stuff
Pevious Jeeps: 1975 Cherokee, 2008 JK, 2005 KJ, 1989 XJ

User avatar

67GMC
Posts: 110
Joined: Thu Mar 03, 2016 5:17 am
Location: Fort Erie, Canada

Re: Radio feedback

Post by 67GMC » Sat May 11, 2019 6:39 am

Not sure but I would check to see the radio chassis is well grounded and that the antenna mast is grounded too. Check that the old capacitor off the ignition coil is still intact. Normally, this causes more an issue with AM though as you point out. On FM, I remember getting a whine that would go up and down with the engine speed. That required some RFI box between the antenna and the radio to remove.
My Stable:
1984 Jeep Grand Wagoneer, 360 V8, Auto, SelecTrac
1987 Jeep Cherokee (XJ), 4.0L I6, Auto, Selectrac
And a few more....


Topic author
hanger
Posts: 44
Joined: Sun Dec 16, 2018 8:09 am

Re: Radio feedback

Post by hanger » Sun May 12, 2019 6:04 pm

Funny thing is the radio reception isn’t affected I just get feedback static mainly during vocals of a song. Sometimes it works fine for a week and then starts doing it again. Crazy.

User avatar

TeaBag
Posts: 120
Joined: Wed Oct 09, 2013 1:22 pm
Location: Chicago

Re: Radio feedback

Post by TeaBag » Mon May 20, 2019 12:39 pm

My guess is that it is likely something internal to the radio itself and in which case, would not be worth trying to fix. Likely cheaper to replace the unit.

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests