4.0 issues

Area for post regarding Jeeps other than an FSJ. This area may contain technical post regarding those vehicles as well.
User avatar
Stuka
Site Admin
Posts: 7495
Joined: Thu May 12, 2011 5:53 pm
Location: Sonora, CA
Contact:

Re: 4.0 issues

Postby Stuka » Fri May 19, 2017 4:46 pm

I knew I had recalled it being in there. Some places call it the Distributer Plate Switch.

Image
1981 J10 AMC 258 with HEI and Weber 32/36 DGEV Carb, T176, NP208, D44/M23 with 4.56 gears and Detroit Locker, 6" lift, 33x12.50 Cooper STT's, BJ's Offroad Rear Dozer Bumper.
1975 Cherokee *Sold* :(
2008 JK 3.8, 6sp, NP241, 2.5" lift, 33's, 4.56's
1989 XJ Limited *Sold*
2005 KJ Limited *Sold*

User avatar
tedlovesjeeps71
Posts: 1635
Joined: Fri Jul 22, 2016 4:39 pm

Re: 4.0 issues

Postby tedlovesjeeps71 » Fri May 19, 2017 4:47 pm

I'll eat my crow and humbly apologize to all.


Sent from my iPhone using Tapatalk

User avatar
jpswapmohn
Posts: 230
Joined: Sun Mar 02, 2014 6:08 pm
Location: Ft. Bragg, NC

Re: 4.0 issues

Postby jpswapmohn » Fri May 19, 2017 5:02 pm

Weren't the 98's OBD2? Throwing any codes?

This may help:
https://www.cherokeeforum.com/f2/jeep-c ... bdii-3341/

My 95 is OBD1 and i just use the ignition on-off-on-off-on to read the flashes
One day I will wake up and realize that my jeep is complete...one day, I just know it.
88Wag, LT1/4L60E/NP242, etc.
95YJ, STaK, D44's, SOA, ARB's, Bilstein 5150s, 35" KM2's
50 CJ3A
77 J-10 (sold)
http://s552.photobucket.com/albums/j...wapmohn/Jeeps/

User avatar
Curly
Posts: 143
Joined: Fri Mar 13, 2015 11:31 pm

Re: 4.0 issues

Postby Curly » Fri May 19, 2017 7:52 pm

Shagoneer wrote:Image


That sure sounds like a relay with a bad ground. Can you tell by touching the relay which one is making the noise?
I start what I finish.

77 Cherokee S
97 Jeep Wrangler

User avatar
Curly
Posts: 143
Joined: Fri Mar 13, 2015 11:31 pm

Re: 4.0 issues

Postby Curly » Fri May 19, 2017 7:53 pm

Can you get codes or data from the DLC (connector for computer that is normally under the dash)?
I start what I finish.

77 Cherokee S
97 Jeep Wrangler

User avatar
Shagoneer
Posts: 311
Joined: Wed Mar 27, 2013 11:14 am
Location: Socorro, NM

Re: 4.0 issues

Postby Shagoneer » Fri May 19, 2017 8:04 pm

Curly wrote:Can you get codes or data from the DLC (connector for computer that is normally under the dash)?


Already hooked an obd2 scanner up and it didn't have any codes.

I will double check all of the relays before I work tomorrow.

I will buy a multi meter Wednesday when I get paid so that I can check voltage at the plugs and at the coil.
Currently without an FSJ, relying on a baby Jeep and a mustang, until I find a J Truck or M715 I want.

User avatar
Stuka
Site Admin
Posts: 7495
Joined: Thu May 12, 2011 5:53 pm
Location: Sonora, CA
Contact:

Re: 4.0 issues

Postby Stuka » Fri May 19, 2017 8:09 pm

Shagoneer wrote:
Curly wrote:Can you get codes or data from the DLC (connector for computer that is normally under the dash)?


Already hooked an obd2 scanner up and it didn't have any codes.

I will double check all of the relays before I work tomorrow.

I will buy a multi meter Wednesday when I get paid so that I can check voltage at the plugs and at the coil.


No need for a voltometer, most wont handle that voltage anyway. Just pull a plug, hook it back to the wire, ground threads, and have somebody turn it over. It should spark. If not, we know the issue is in the ignition someplace. If it does spark, its either fuel, or sparking at the wrong time.
1981 J10 AMC 258 with HEI and Weber 32/36 DGEV Carb, T176, NP208, D44/M23 with 4.56 gears and Detroit Locker, 6" lift, 33x12.50 Cooper STT's, BJ's Offroad Rear Dozer Bumper.
1975 Cherokee *Sold* :(
2008 JK 3.8, 6sp, NP241, 2.5" lift, 33's, 4.56's
1989 XJ Limited *Sold*
2005 KJ Limited *Sold*

User avatar
Curly
Posts: 143
Joined: Fri Mar 13, 2015 11:31 pm

Re: 4.0 issues

Postby Curly » Fri May 19, 2017 8:52 pm

I think your problem is going to be related to that buzzing relay. Identify the relay, check its wiring and it will most likely be the cause of the no start.
I start what I finish.

77 Cherokee S
97 Jeep Wrangler

User avatar
Shagoneer
Posts: 311
Joined: Wed Mar 27, 2013 11:14 am
Location: Socorro, NM

Re: 4.0 issues

Postby Shagoneer » Fri May 19, 2017 11:23 pm

Curly wrote:I think your problem is going to be related to that buzzing relay. Identify the relay, check its wiring and it will most likely be the cause of the no start.



Well I still haven't had time to go outside and check, however, as (in stock form) two relays power the ABS, one is the fuel pump (which in my case doesn't matter as the pump is hard wired instead of being on a relay), one is for the horn, and one is the AC unit. That leaves two possible culprits that could actually affect starting 1. The auto shutdown relay, and the starter relay.
As they are $5-$10 each I may replace both, while I am following wires to figure out which one is having problems.
Currently without an FSJ, relying on a baby Jeep and a mustang, until I find a J Truck or M715 I want.

User avatar
Curly
Posts: 143
Joined: Fri Mar 13, 2015 11:31 pm

Re: 4.0 issues

Postby Curly » Sat May 20, 2017 6:37 am

The ASD relay controls the fuel pump and coil in stock former. Since you seem to have no spark, it's most likely that ASD relay buzzing.
I start what I finish.

77 Cherokee S
97 Jeep Wrangler

User avatar
Shagoneer
Posts: 311
Joined: Wed Mar 27, 2013 11:14 am
Location: Socorro, NM

Re: 4.0 issues

Postby Shagoneer » Sat May 20, 2017 7:42 am

I'll probably try it with the horn relay in the asd relay location, to see if it's just Abbas relay or if it's a wiring issue.
Currently without an FSJ, relying on a baby Jeep and a mustang, until I find a J Truck or M715 I want.

User avatar
Shagoneer
Posts: 311
Joined: Wed Mar 27, 2013 11:14 am
Location: Socorro, NM

Re: 4.0 issues

Postby Shagoneer » Sat May 20, 2017 8:06 am

Ok after switching the relays it's no longer buzzing, but it still won't start.

So now I'm going to check spark
Currently without an FSJ, relying on a baby Jeep and a mustang, until I find a J Truck or M715 I want.

User avatar
Shagoneer
Posts: 311
Joined: Wed Mar 27, 2013 11:14 am
Location: Socorro, NM

Re: 4.0 issues

Postby Shagoneer » Sat May 20, 2017 8:47 am

So my genius #?*! broke one of the spark plugs while removing it to do a spark test. The plug appears to be in decent shape (other than being broken in half), however the model of plug was discontinued somewhere between 2007 and 2009 (reading different dates different places).

So I guess I will change out my decade old plugs while I'm doing everything else:
Currently without an FSJ, relying on a baby Jeep and a mustang, until I find a J Truck or M715 I want.

User avatar
Cecil14
Posts: 318
Joined: Mon Oct 01, 2012 6:40 am
Location: Lansing, MI

Re: 4.0 issues

Postby Cecil14 » Sun May 21, 2017 12:27 pm

Is it a stock ECU? Have you tried swapping that out? I've killed an ECU or two in my truck over the years. They're generally pretty cheap anymore.


aa
Anthony

1983 J-10 - 4.6L(MPFI)/CS130D/NV3550/D300/44/44/3.54/32s/42 gallon 'burb tank

User avatar
Shagoneer
Posts: 311
Joined: Wed Mar 27, 2013 11:14 am
Location: Socorro, NM

Re: 4.0 issues

Postby Shagoneer » Thu May 25, 2017 9:23 am

I've got spark, and I've got fuel, but still won't start
Currently without an FSJ, relying on a baby Jeep and a mustang, until I find a J Truck or M715 I want.

User avatar
tedlovesjeeps71
Posts: 1635
Joined: Fri Jul 22, 2016 4:39 pm

Re: 4.0 issues

Postby tedlovesjeeps71 » Thu May 25, 2017 11:45 am

Did you only test one plug or do all 6 have spark?


Sent from my iPhone using Tapatalk

User avatar
Shagoneer
Posts: 311
Joined: Wed Mar 27, 2013 11:14 am
Location: Socorro, NM

Re: 4.0 issues

Postby Shagoneer » Thu May 25, 2017 12:53 pm

I only tested number one. I guess I ought to check all 6.
Currently without an FSJ, relying on a baby Jeep and a mustang, until I find a J Truck or M715 I want.

User avatar
Cecil14
Posts: 318
Joined: Mon Oct 01, 2012 6:40 am
Location: Lansing, MI

Re: 4.0 issues

Postby Cecil14 » Thu May 25, 2017 6:51 pm

If you know anyone else with a similar year 4.0L, just swap the ECU. Or, if there's a cheap pick n pull around, grab a spare. I think ECUs are like $25 at my local yard, I keep a known good spare behind the seat.


aa
Anthony

1983 J-10 - 4.6L(MPFI)/CS130D/NV3550/D300/44/44/3.54/32s/42 gallon 'burb tank

User avatar
Shagoneer
Posts: 311
Joined: Wed Mar 27, 2013 11:14 am
Location: Socorro, NM

Re: 4.0 issues

Postby Shagoneer » Thu May 25, 2017 8:23 pm

Will a Cherokee Ecu for a wrangler? I know here we're some years with minor differences.
Currently without an FSJ, relying on a baby Jeep and a mustang, until I find a J Truck or M715 I want.

User avatar
tedlovesjeeps71
Posts: 1635
Joined: Fri Jul 22, 2016 4:39 pm

Re: 4.0 issues

Postby tedlovesjeeps71 » Thu May 25, 2017 9:20 pm

Shagoneer wrote:Will a Cherokee Ecu for a wrangler? I know here we're some years with minor differences.


I think it would have to be pretty similar. Within the same year spectrum, same transmission type, etc.


Sent from my iPhone using Tapatalk


Return to “General Other Jeep Related Chat”

Who is online

Users browsing this forum: No registered users and 2 guests