Holley Sniper EFI on 401

For everything related to using Fuel Injection in an FSJ.
User avatar
Tatsadasayago
Posts: 3638
Joined: Thu Aug 28, 2014 2:22 pm
Location: Sacramento, CA

Re: Holley Sniper EFI on 401

Postby Tatsadasayago » Mon Jul 03, 2017 4:47 pm

They will sing songs around the campfires about your 14mm Tap Sir!
1977 Cherokee Chief - The Blair Jeep Project III
A collection of parts flying in close formation

User avatar
az chip
Posts: 1177
Joined: Tue Jul 14, 2015 8:59 pm
Location: Mesa, AZ

Re: Holley Sniper EFI on 401

Postby az chip » Mon Jul 03, 2017 5:16 pm

Not sure about songs. But a raise a beer in respect, oh yeah.


Sent from my iPhone using Tapatalk
'81 Cherokee Chief 81 WT Chief/MSD 6/ Rusty 4" Spring lift/ Bulltear oil adapter/K&P Engineering Oil Filter/ NP 208/ Serehill Light Harness/ H4 Headlights/ Evil Twin Fab Luggage rack and sliders/ Ross mirror mounts.

FSJ Guy
Posts: 1678
Joined: Fri Mar 15, 2013 3:03 pm

Re: Holley Sniper EFI on 401

Postby FSJ Guy » Tue Jul 04, 2017 8:54 am

Awesome!!!

Holley sure has come a long way since there analog "fuel injection" system!! Looks real nice!
Ethan Brady

http://www.bigscaryjeep.com

1987 Grand Wagoneer. Slightly longer than stock.

User avatar
KJ Ryu
Posts: 823
Joined: Sun Jun 10, 2012 8:03 am
Location: Casper

Re: Holley Sniper EFI on 401

Postby KJ Ryu » Sat Jul 15, 2017 6:53 pm

Still loving EFI. Hedman shipped out my header gaskets yesterday so next weekend, I'm hoping it gets even better! I've already noticed a bit of gain in mileage. Don't have real numbers yet but with the carb, today would have been the day I'd be on empty. Instead, about 3/8 of a tank left. :-bd
Ron

2005 KJ, Hit-n-Run, 2am 6-17-2012, Totaled. :mad:
1977 SJ J10, 2v304, T18, D20, 37x14s, SOA & SF on tons, still ugly. not running
1978 SJ Wagoneer, 4v360, QT, 33x12.5s, lift by Sawzall :-bd NOT Running :(
1977 SJ J10, SniperEFI 401, QT, D44s, 31X10.5s, DD! :fsj:

Mars wrote:One man's trans leak is another's penetrating oil :D

User avatar
Stuka
Site Admin
Posts: 7844
Joined: Thu May 12, 2011 5:53 pm
Location: Sonora, CA
Contact:

Re: Holley Sniper EFI on 401

Postby Stuka » Sun Jul 16, 2017 8:25 am

Somehow I missed this thread. Awesome that it's working so well now. Heard a lot of good things about the sniper setup.

As a curiosity, why do you want your idle to be at 500?
1981 J10 AMC 258 with HEI and Weber 32/36 DGEV Carb, T176, NP208, D44/M23 with 4.56 gears and Detroit Locker, 6" lift, 33x12.50 Cooper STT's, BJ's Offroad Rear Dozer Bumper.
2017 JKU Rubicon Stock
Pevious Jeeps: 1975 Cherokee, 2008 JK, 2005 KJ, 1989 XJ

User avatar
REDONE
Posts: 2373
Joined: Tue Sep 13, 2011 5:48 pm
Location: Lakewood and Bailey, CO

Re: Holley Sniper EFI on 401

Postby REDONE » Sun Jul 16, 2017 8:36 am

Stuka wrote:
As a curiosity, why do you want your idle to be at 500?

From my reading of the thread, he's supposed to set the idle around 500 with a sensor (coolant temp?) unplugged, so that when it's plugged back in it raises the idle to 700. It looks like the coolant sensor was a known issue of some kind, and this was the work around or something.
79 J-10 (The Money Badger) KE0LSU
304/Performance Fuel Injection TBI/MTA1/SP2P/Magnum rockers
T18/D20/D44s/33" Mud Claws
Grizzly Locker Rear
4" front spring drop, 5" rear shackle flip
Chevy style HEI (ECM controlled)
Dolphin "Shark" gauges in a fancy homemade oak bezel
3/4 resto, rotting faster than I've been fixing it.

User avatar
KJ Ryu
Posts: 823
Joined: Sun Jun 10, 2012 8:03 am
Location: Casper

Re: Holley Sniper EFI on 401

Postby KJ Ryu » Mon Jul 17, 2017 11:42 am

Without the sensor, it would enrich so much that, in order to get it to idle at 700, I had to tell it to idle lower. Now that the sensor is hooked up and it runs so well, I have the idle set at 600 and it idles at 600. Doesn't slam into reverse as hard as it was at 700rpm.
Ron

2005 KJ, Hit-n-Run, 2am 6-17-2012, Totaled. :mad:
1977 SJ J10, 2v304, T18, D20, 37x14s, SOA & SF on tons, still ugly. not running
1978 SJ Wagoneer, 4v360, QT, 33x12.5s, lift by Sawzall :-bd NOT Running :(
1977 SJ J10, SniperEFI 401, QT, D44s, 31X10.5s, DD! :fsj:

Mars wrote:One man's trans leak is another's penetrating oil :D

grnhornetcustoms
Posts: 31
Joined: Mon Sep 21, 2015 4:10 pm

Re: Holley Sniper EFI on 401

Postby grnhornetcustoms » Sat Jul 29, 2017 1:47 pm

I have been running this system for a couple weeks now on my CJ5. Made a big difference all around and on Trails.


Sent from my iPad using Tapatalk

User avatar
KJ Ryu
Posts: 823
Joined: Sun Jun 10, 2012 8:03 am
Location: Casper

Re: Holley Sniper EFI on 401

Postby KJ Ryu » Sun Jul 30, 2017 7:36 am

I've already decided that once I can afford it, my off-road truck will be getting the same setup. Never had a lot of trouble from my 2150 but I know EFI would be worlds better.
Ron

2005 KJ, Hit-n-Run, 2am 6-17-2012, Totaled. :mad:
1977 SJ J10, 2v304, T18, D20, 37x14s, SOA & SF on tons, still ugly. not running
1978 SJ Wagoneer, 4v360, QT, 33x12.5s, lift by Sawzall :-bd NOT Running :(
1977 SJ J10, SniperEFI 401, QT, D44s, 31X10.5s, DD! :fsj:

Mars wrote:One man's trans leak is another's penetrating oil :D

User avatar
KJ Ryu
Posts: 823
Joined: Sun Jun 10, 2012 8:03 am
Location: Casper

Re: Holley Sniper EFI on 401

Postby KJ Ryu » Mon Jul 31, 2017 4:48 pm

10.413mpg!!! Sounds terrible but, considering the race cam, high compression, etc. of the motor, it's about the best I can hope for, I think. That's almost double what I was getting with the 750cfm Edelbrock carb, and some of those miles were driven before I got the exhaust gaskets replaced. Very pleased with the Sniper, now. :D :fsj: :D
Ron

2005 KJ, Hit-n-Run, 2am 6-17-2012, Totaled. :mad:
1977 SJ J10, 2v304, T18, D20, 37x14s, SOA & SF on tons, still ugly. not running
1978 SJ Wagoneer, 4v360, QT, 33x12.5s, lift by Sawzall :-bd NOT Running :(
1977 SJ J10, SniperEFI 401, QT, D44s, 31X10.5s, DD! :fsj:

Mars wrote:One man's trans leak is another's penetrating oil :D

User avatar
bwwhaler
Posts: 188
Joined: Thu Oct 04, 2012 6:33 am
Location: Wilmington NC

Re: Holley Sniper EFI on 401

Postby bwwhaler » Tue Aug 08, 2017 1:00 pm

Awesome write up... maybe I missed it, what are you using for fuel pump? I am impressed by your experience and am looking forward to getting TBI... Where did you source your parts?
1987 GW 360/727/229 Performer intake Holley 670 32's 4" BJ's Springs CS-144 Serehill's light and tailgate harness

User avatar
swanny1911
Posts: 59
Joined: Fri Aug 12, 2016 4:13 pm
Location: Idaho

Holley Sniper EFI on 401

Postby swanny1911 » Wed Aug 09, 2017 6:12 pm

I am in the middle of installing a Holley Sniper on my AMC 360. I still have to upgrade the fuel lines to 3/8". I also ordered a fuel tank from BJ's Off-road, which included a Walbro fuel pump. I still have to have the fuel pump assembly modified to fit all of the fuel lines and I should be good to go. Thank you for posting info on your install!

Did you set yours up for timing control? If so, what ignition setup are you using and distributor?


1988 Grand Wagoneer, TFI, Streetfire Ignition, 2" Body Lift
1988 Grand Wagoneer, AMC 360, Streetfire ignition, TFI, 2" body lift, Holley Sniper, Stainless Brain Fabrication Fuel Tank, Evil Twin Fab spare tire carrier. :fsj:

User avatar
KJ Ryu
Posts: 823
Joined: Sun Jun 10, 2012 8:03 am
Location: Casper

Re: Holley Sniper EFI on 401

Postby KJ Ryu » Wed Aug 09, 2017 6:37 pm

bwwhaler wrote:Awesome write up... maybe I missed it, what are you using for fuel pump? I am impressed by your experience and am looking forward to getting TBI... Where did you source your parts?


I purchased the "Master kit with fuel system" direct from Holley, so, just an inline pump. If I'd done some research before ordering I would have gone through efisystempro.com. They have them in stock when nobody else does.

swanny: Holley, and everyone else, recommends not running timing control when first installing EFI. I just have a HEI on it, for now. Still running on vacuum and mechanical advance.
Ron

2005 KJ, Hit-n-Run, 2am 6-17-2012, Totaled. :mad:
1977 SJ J10, 2v304, T18, D20, 37x14s, SOA & SF on tons, still ugly. not running
1978 SJ Wagoneer, 4v360, QT, 33x12.5s, lift by Sawzall :-bd NOT Running :(
1977 SJ J10, SniperEFI 401, QT, D44s, 31X10.5s, DD! :fsj:

Mars wrote:One man's trans leak is another's penetrating oil :D

User avatar
swanny1911
Posts: 59
Joined: Fri Aug 12, 2016 4:13 pm
Location: Idaho

Re: Holley Sniper EFI on 401

Postby swanny1911 » Thu Aug 10, 2017 2:52 am

I plan on doing the same. I have read that some people encounter issues adding timing control with a MSD ignition or distributor. I wished Holley made the dual sync distributor for AMC engines.


1988 Grand Wagoneer, TFI, Streetfire Ignition, 2" Body Lift
1988 Grand Wagoneer, AMC 360, Streetfire ignition, TFI, 2" body lift, Holley Sniper, Stainless Brain Fabrication Fuel Tank, Evil Twin Fab spare tire carrier. :fsj:

User avatar
KJ Ryu
Posts: 823
Joined: Sun Jun 10, 2012 8:03 am
Location: Casper

Re: Holley Sniper EFI on 401

Postby KJ Ryu » Thu Aug 10, 2017 5:33 pm

swanny1911 wrote:I wished Holley made the dual sync distributor for AMC engines.


So do I. If I could afford to throw money away on it, I'd buy one, just to see if I could machine it to fit an AMC. People did it with HEIs before anyone made them specifically for our engines, so I'm sure it's possible but, like I said... money I can't afford to throw away if I mess it up.
Ron

2005 KJ, Hit-n-Run, 2am 6-17-2012, Totaled. :mad:
1977 SJ J10, 2v304, T18, D20, 37x14s, SOA & SF on tons, still ugly. not running
1978 SJ Wagoneer, 4v360, QT, 33x12.5s, lift by Sawzall :-bd NOT Running :(
1977 SJ J10, SniperEFI 401, QT, D44s, 31X10.5s, DD! :fsj:

Mars wrote:One man's trans leak is another's penetrating oil :D

User avatar
KJ Ryu
Posts: 823
Joined: Sun Jun 10, 2012 8:03 am
Location: Casper

Re: Holley Sniper EFI on 401

Postby KJ Ryu » Mon Oct 02, 2017 4:39 pm

Well, the "Holley" brand o2 sensor died last week. I knew something was going wrong 'cause my mileage kept getting worse with each fill-up. Replaced it with a Bosch (part #17025) and got the best mileage I've seen this truck get, ever. 11.314mpg and some of that was driven with the EFI in open-loop/nolearn mode because I had to wait three days to get the sensor. Parts stores do not carry it. Had to order from Amazon.
Ron

2005 KJ, Hit-n-Run, 2am 6-17-2012, Totaled. :mad:
1977 SJ J10, 2v304, T18, D20, 37x14s, SOA & SF on tons, still ugly. not running
1978 SJ Wagoneer, 4v360, QT, 33x12.5s, lift by Sawzall :-bd NOT Running :(
1977 SJ J10, SniperEFI 401, QT, D44s, 31X10.5s, DD! :fsj:

Mars wrote:One man's trans leak is another's penetrating oil :D

FSJ Guy
Posts: 1678
Joined: Fri Mar 15, 2013 3:03 pm

Re: Holley Sniper EFI on 401

Postby FSJ Guy » Mon Oct 02, 2017 10:15 pm

Not sure why they don't recommend adding timing control. IMHO, that's one of the great benefits of putting EFI on an FSJ!!
<shrug>
Ethan Brady

http://www.bigscaryjeep.com

1987 Grand Wagoneer. Slightly longer than stock.

User avatar
KJ Ryu
Posts: 823
Joined: Sun Jun 10, 2012 8:03 am
Location: Casper

Re: Holley Sniper EFI on 401

Postby KJ Ryu » Tue Oct 03, 2017 11:34 am

They recommend it but, suggest that you get it running on the EFI with existing setup, first. One major hurdle at a time sort of thing, I guess.
Ron

2005 KJ, Hit-n-Run, 2am 6-17-2012, Totaled. :mad:
1977 SJ J10, 2v304, T18, D20, 37x14s, SOA & SF on tons, still ugly. not running
1978 SJ Wagoneer, 4v360, QT, 33x12.5s, lift by Sawzall :-bd NOT Running :(
1977 SJ J10, SniperEFI 401, QT, D44s, 31X10.5s, DD! :fsj:

Mars wrote:One man's trans leak is another's penetrating oil :D

User avatar
KJ Ryu
Posts: 823
Joined: Sun Jun 10, 2012 8:03 am
Location: Casper

Re: Holley Sniper EFI on 401

Postby KJ Ryu » Fri Oct 20, 2017 10:46 am

Just got back from hunting around Lander, WY yesterday. Left last Friday. 150+ miles to Lander and back, quite a bit of low range dirt roads while looking for deer, some highway miles to get to dirt roads, some town streets for lunch and reminiscing (used to live in Lander and will again, someday.); only filled up 3 times! Over 12mpg average! :fsj: :-bd
Ron

2005 KJ, Hit-n-Run, 2am 6-17-2012, Totaled. :mad:
1977 SJ J10, 2v304, T18, D20, 37x14s, SOA & SF on tons, still ugly. not running
1978 SJ Wagoneer, 4v360, QT, 33x12.5s, lift by Sawzall :-bd NOT Running :(
1977 SJ J10, SniperEFI 401, QT, D44s, 31X10.5s, DD! :fsj:

Mars wrote:One man's trans leak is another's penetrating oil :D

User avatar
az chip
Posts: 1177
Joined: Tue Jul 14, 2015 8:59 pm
Location: Mesa, AZ

Re: Holley Sniper EFI on 401

Postby az chip » Fri Oct 20, 2017 5:48 pm

Nice. Do you have a link for pics?
'81 Cherokee Chief 81 WT Chief/MSD 6/ Rusty 4" Spring lift/ Bulltear oil adapter/K&P Engineering Oil Filter/ NP 208/ Serehill Light Harness/ H4 Headlights/ Evil Twin Fab Luggage rack and sliders/ Ross mirror mounts.


Return to “FSJ Fuel Injection Tech”

Who is online

Users browsing this forum: No registered users and 2 guests