Interior Lights Dont Work???

Stock FSJ Tech Area
Fast79Chief
Posts: 193
Joined: Wed May 09, 2018 7:10 am
Location: Eastern Pennsylvania

Interior Lights Dont Work???

Postby Fast79Chief » Thu Sep 20, 2018 4:22 pm

I replaced the bulbs in the maplight and the rear cargo light, checked the fuse panel, all fuses are good ... but no lights when I turn the dash light switch all the way to the right.

Any ideas what else might be wrong here?

Thanks.
1979 Cherokee Chief S, 360, MSD Pro Billet Distributor with Factory Ignition Box (Wow), HEI Wires, Edelbrock 1406, Edelbrock Performer manifold, 3.54 gears, Tru-Trac Locker in the rear, Turbo 400, Quadratrac, Dual tanks, new 32 x 11.50's, big winch, Homemade 2.5" full length exhaust ... and a lot of work to do. :)

GrandW
Posts: 33
Joined: Mon Aug 20, 2018 6:19 pm

Re: Interior Lights Dont Work???

Postby GrandW » Thu Sep 20, 2018 8:56 pm

May be try these steps:
Verify the plug is getting voltage - use a voltameter to verify power is reaching the plug
Verify the light works - unplug the connector, use a battery or power probe to ensure the unit lights up
Verify the ground is good

If one of these aren't good, then you may have to trace it back / replace or repair.... let us know what the solution is!
1987 Jeep Grand Wagoneer

Fast79Chief
Posts: 193
Joined: Wed May 09, 2018 7:10 am
Location: Eastern Pennsylvania

Re: Interior Lights Dont Work???

Postby Fast79Chief » Fri Sep 21, 2018 8:57 am

Thanks GrandW, I went back at it with a test light and found no power along the wire anywhere. So back to the fuse panel, found a 25 amp fuse high up in the panel was blown. Got past me the first time looking. lol. Now to get the little Map bulbs to light up.
Thanks again.
1979 Cherokee Chief S, 360, MSD Pro Billet Distributor with Factory Ignition Box (Wow), HEI Wires, Edelbrock 1406, Edelbrock Performer manifold, 3.54 gears, Tru-Trac Locker in the rear, Turbo 400, Quadratrac, Dual tanks, new 32 x 11.50's, big winch, Homemade 2.5" full length exhaust ... and a lot of work to do. :)

candymancan
Posts: 1860
Joined: Tue Mar 22, 2016 11:32 pm

Re: Interior Lights Dont Work???

Postby candymancan » Thu Sep 27, 2018 2:39 am

Check the wiring under the drivers seat... On my 90 the overhead lights bever worked when i got it... the wiring was corroded and the plugs fell apart.. from water leaking in the Jeep..

Cut the plugs off and i had to cut back the wiring like 12 incjes in some spots to get the black copper away and it fixed it
2013 SS camaro, cammed, and modded too much to say 500 RWHP/650 crank 30k
1998 Jeep Grand Cherokee 5.9L Limited 191k
1998 Jeep Grand Cherokee 4.0 I6 laredo 256k
1990 Jeep Grand Wagoneer 126k


Return to “Stock FSJ Tech”

Who is online

Users browsing this forum: No registered users and 9 guests